Supported Browsers in Canvas

According to the Browser Canvas Guide, the following browsers are supported in Canvas. UNC suggests:

  • Edge
  • Chrome 50 and 51
  • Safari 8 and 9
  • Firefox 45 and 46 (Extended Releases are not supported)
  • Flash 20 and 21 (used for recording or viewing audio/video and uploading files)

UNC faculty and students have reported decreased functionality in Canvas when using Internet Explorer.

Some supported browsers may still produce a banner stating "Your browser does not meet the minimum requirements for Canvas". If you have upgraded your browser but you are still seeing the warning banner, log out of Canvas and delete your browser cookies/history. Learn how to clear your cache on a Mac or a PC.